A validation exception occurred - Account code xxx has been archived, or has been deleted

How to fix this error with Xero and Cloud Depot

Cause

This error is caused by a user deleting an account code in Xero and not removing the account code mapping in Cloud Depot.

To fix this error identify which account has been deleted in Xero, our sync alert system will tell you in the logs or by email, example below:

A validation exception occurred - Account code '270' has been archived, or has been deleted

How to resolve this issue

Cloud Depot - > My Accounting Toolbox -> Configuration -> Link Account Codes

1. Log into Cloud Depot and navigate to Link Account Codes

2. Use the search feature to locate the mapped account code in our example it is 270 (yours will be different)

3. Click Delete to remove the mapping

4. If the deleted account code in Xero has been replaced with a new account code in Xero you might want to now map that new account code to the Autotask account code.

5. Resync the affected invoice(s)